Include inherited authentication in Documentation


#1

Hi,

When authentication is set as inherited in a collection, the collection documentations shows requests as unauthenticated.

In my case, since all requests are authenticated, and all use the same details, auth is set on collection level and is inherited everywhere (which seems to be the default as there is no mention of auth in the collection export json when inheritance is used)

Screenshots in my other thread about GET request parameters not showing up in the documentation include proof of this one as well (although you will have to take my word for it, that authentication IS configured on collection level :slight_smile: )


#2

I have the exact same problem. Authorization headers (Basic and Bearer) are not shown at all in the documentation. That of course results in incorrect code being generated.
This happens for inherited authorization as well as authorization on the request level. The only difference is that on the request level a small lock is shown (which is probably supposed to show that this call is not publicly accessible). But doesn’t change anything else:

image

More information in this thread: Show Authorization Header on documentation?


#3

Still no answer from the Postman team about this bug ?

My workaround for now is to stop using the option Inherit from parent and set Authorization for each Request manually.


#4

The inherited auth should already be showing up as a “lock” in both the private and public docs. We’re still working on figuring the best way to display the actual auth helper in the docs.


#5

@jean_tymate that’s what I also did. Not pretty (at all) but somehow works.
@godfrzero The lock item doesn’t help at all.


#6

@godfrzero any updates on this issue?