Losing all collections when updating Postman to v7.0.6

This is very urgent, I lost all my collections/projects and can’t restore it from Trash.

I got popup today in the middle of my work saying that if I want to upgrade to version 7.0.6 either now or later. I selected later and it says ‘if you select later you can still recover your projects and then it asked me to delete all my local files, which I did.
When I logged again, my files were gone.

When I go to MyWorkspace | Team tab I see message ‘You need to have an active internet connection to be able to switch to or create a workspace’. Before this message was saying for long time ‘trying to Sync’.

If I go to Upgrade dropdown in top right corner, pop up ‘Enable Sync to view your team’ comes up with button ‘Enable Sync’. I keep clicking on this button but it doesn’t do anything.

I tried to recover my files from Dashboard Trash - but my files are not there. I thought they are saved for minimum one day!!??

I looked in Recycle Bin but I don’t see files there.

I don’t keep my files on Git, I back them up to local network drive every Friday, so I lost the work for whole this week.

My Postman version is v 7.0.6, my Windows version is Windows 7, Service pack 1.

Thanks in advance,

Mike

Hey Mike – I’ve responded to your support request. Let’s continue the conversation there. I’ll circle back up on this thread once we’ve closed out the support thread!

+1 I just upgraded to Postman 7, to fix a syncing problem (cloud connection failing). Now my cloud sync is working, but all my local collections are gone (b/c they never previously synced to cloud).

@zbeat

Sorry to hear that. If you haven’t logged out of Postman yet could you go to Settings > Data > Export Data and select Download all data including data in workspaces I have joined and try importing them again?

2 Likes

That fixed it :tada:

No idea why :man_shrugging:

Hey @zbeat Thats because the collections were always there, however they were not shown in your active workspace. We are still continuing to investigate why that might have happened.

In the meantime the workaround should unblock anyone stumbling on this thing.