My postman is responses is showing 0.00 as 0E-9

Please search for related topics, and then read through the guidelines before creating a new issue.
Currently using v7.3.2 of postman. I am seeing decimal responses as “0E9”. However, in older versions of postman I see the response as “0.0”.
Describe the bug
Issue with response for decimal type data.

To Reproduce
Steps to reproduce the behavior:

  1. Performing GET calls on the application.

Expected behavior
A clear and concise description of what you expected to happen.

Screenshots
Current output seen:

Output seen on 7.2.2 of postman

App information (please complete the following information):
Postman Desktop 7.3.2

Additional context
Add any other context about the problem here.

@thelakkat Hello and welcome to the community! :wave:

Please fill in the required information regarding what the bug is and also the app information.
Please explain with screenshots/gifs and also if there’s any regression that was caused then please mention the same.

Thank you.

Hello @sivcan. Added the requested details. Thanks and regards, Karan

@thelakkat - So we no longer parse any values and display exactly what the server sends the response as.
As you can see in your screenshots that the value of amount is now shown as 87.120000000 (screenshot of v7.3.2) instead of 87.12 (as in the screenshot of v7.2.2)
Same with amountWithoutTax and beAppliedAmount etc.

So, if you check in javascript console also, you can see that 0E-9 is 0, which was previously being parsed but we’ve had multiple issues around this parsing where users didn’t want Postman to parse the numbers in any format.
image

Therefore,
This is an intended behaviour and responses are displayed exactly as sent by the server.

I hope this information helps you out. :slight_smile: